If you register, you can do a lot more. And become an active part of our growing community. You'll have access to hidden forums, and enjoy the ability of replying and starting conversations.

TV Interference!

Discussion in 'Model Railways' started by 83B, Jan 29, 2010.

  1. 83B

    83B Member

    Joined:
    Oct 11, 2005
    Messages:
    314
    Likes Received:
    121
    I incur the wrath of my partner whenever I run a Bachmann loco because it causes terrible interference with the HD Plasma TV with the picture breaking up and sound distorted. I have an old analogue TV set and that is not affected.

    The Hornby locos pose no such problems with no hint of any interference at all.

    It just seems that Bachmann locos are not well surpressed or surpressed at all? I can't be the only person in this situation and if there is a solution, I would welcome some advice.

    If it was happening with all locos, it would point to the house electrics but it isn't - Bachmann only!
     
  2. gz3xzf

    gz3xzf Member

    Joined:
    Jul 22, 2006
    Messages:
    286
    Likes Received:
    43
    Gender:
    Male
    Occupation:
    Retired
    Location:
    21C142
    Heritage Railway Volunteer:
    Yes I am an active volunteer
    Hi there 83B

    Are you running DC or DCC?

    In my limited experience Hornby appear to fit both inductors and capacitors to their locomotives, but I haven't yet had the need to take one of my Bachmann locos apart; so I have not seen what they use as standard.

    You could also ask the question on the New Railway Modelling Forums and see if anyone has experienced the same problems.
     

Share This Page